What’s Vulnerable › Vulnerabilities
CVE-2021-24230: Patreon WordPress < 1.7.0 - CSRF to Overwrite/Create User Meta
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Jetpack Scan team identified a Cross-Site Request Forgery vulnerability in the Patreon WordPress plugin before 1.7.0, allowing attackers to make a logged in user overwrite or create arbitrary user metadata on the victim’s account once visited. If exploited, this bug can be used to overwrite the “wp_capabilities” meta, which contains the affected user account’s roles and privileges. Doing this would essentially lock them out of the site, blocking them from accessing paid content.
Affected products
- Patreon WordPress: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Patreon WordPress 1.7.0. Check the vendor advisory for mitigations.
References
- https://jetpack.com/2021/03/26/vulnerabilities-found-in-patreon-wordpress-plugin/
- https://wpscan.com/vulnerability/2deefa2d-3043-42e5-afef-a42c37703531
- https://jetpack.com/2021/03/26/vulnerabilities-found-in-patreon-wordpress-plugin/
- https://wpscan.com/vulnerability/2deefa2d-3043-42e5-afef-a42c37703531
Get alerted when CVE-2021-24230 or the next vulnerability affects your stack