What’s Vulnerable › Vulnerabilities
CVE-2021-24234: Ivory Search < 4.6.1 - Reflected Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Search Forms page of the Ivory Search WordPress lugin before 4.6.1 did not properly sanitise the tab parameter before output it in the page, leading to a reflected Cross-Site Scripting issue when opening a malicious crafted link as a high privilege user. Knowledge of a form id is required to conduct the attack.
Affected products
- vinod-dalvi Ivory Search – WordPress Search Plugin: before 4.6.1 — fixed in 4.6.1
How to fix
Upgrade to a fixed version: vinod-dalvi Ivory Search – WordPress Search Plugin 4.6.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ecc620be-8e29-4860-9d32-86b5814a3835
- https://www.getastra.com/blog/911/plugin-exploit/reflected-xss-vulnerability-in-ivory-search-wp-plugin/
- https://www.jinsonvarghese.com/reflected-xss-vulnerability-found-in-ivory-search-plugin/
- https://wpscan.com/vulnerability/ecc620be-8e29-4860-9d32-86b5814a3835
- https://www.getastra.com/blog/911/plugin-exploit/reflected-xss-vulnerability-in-ivory-search-wp-plugin/
- https://www.jinsonvarghese.com/reflected-xss-vulnerability-found-in-ivory-search-plugin/
Get alerted when CVE-2021-24234 or the next vulnerability affects your stack