What’s Vulnerable › Vulnerabilities
CVE-2021-24241: Advanced Custom Field Pro < 5.9.1 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Custom Fields Pro WordPress plugin before 5.9.1 did not properly escape the generated update URL when outputting it in an attribute, leading to a reflected Cross-Site Scripting issue in the update settings page.
Affected products
- WP Engine Advanced Custom Fields: before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: WP Engine Advanced Custom Fields 5.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/jdordonezn/Reflected-XSS-in-WordPress-for-ACF-PRO-before-5.9.1-plugin/issues/1
- https://wpscan.com/vulnerability/d1e9c995-37bd-4952-b88e-945e02e3c83f
- https://www.advancedcustomfields.com/blog/acf-5-9-1-release/
- https://github.com/jdordonezn/Reflected-XSS-in-WordPress-for-ACF-PRO-before-5.9.1-plugin/issues/1
- https://wpscan.com/vulnerability/d1e9c995-37bd-4952-b88e-945e02e3c83f
- https://www.advancedcustomfields.com/blog/acf-5-9-1-release/
Get alerted when CVE-2021-24241 or the next vulnerability affects your stack