What’s Vulnerable › Vulnerabilities
CVE-2021-24242: Tutor LMS < 1.8.8 - Authenticated Local File Inclusion
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-22 · updated 2026-06-17
- Weakness: CWE-22
Description
The Tutor LMS – eLearning and online course solution WordPress plugin before 1.8.8 is affected by a local file inclusion vulnerability through the maliciously constructed sub_page parameter of the plugin's Tools, allowing high privilege users to include any local php file
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.8.8 — fixed in 1.8.8
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.8.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/20f3e63a-31d8-49a0-b4ef-209749feff5c
- https://wpscan.com/vulnerability/20f3e63a-31d8-49a0-b4ef-209749feff5c
Get alerted when CVE-2021-24242 or the next vulnerability affects your stack