What’s Vulnerable › Vulnerabilities
CVE-2021-24245: Stop Spammers < 2021.9 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Stop Spammers WordPress plugin before 2021.9 did not escape user input when blocking requests (such as matching a spam word), outputting it in an attribute after sanitising it to remove HTML tags, which is not sufficient and lead to a reflected Cross-Site Scripting issue.
Affected products
- Stop Spammers Security | Block Spam Users, Comments, Forms: before 2021.9 — fixed in 2021.9
How to fix
Upgrade to a fixed version: Stop Spammers Security | Block Spam Users, Comments, Forms 2021.9. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162623/WordPress-Stop-Spammers-2021.8-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/5e7accd6-08dc-4c6e-9d19-73e2d7e97735
- http://packetstormsecurity.com/files/162623/WordPress-Stop-Spammers-2021.8-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/5e7accd6-08dc-4c6e-9d19-73e2d7e97735
Get alerted when CVE-2021-24245 or the next vulnerability affects your stack