What’s Vulnerable › Vulnerabilities
CVE-2021-24246: WorkScout Core < 1.3.4 - Authenticated Stored XSS & XFS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Workscout Core WordPress plugin before 1.3.4, used by the WorkScout Theme did not sanitise the chat messages sent via the workscout_send_message_chat AJAX action, leading to Stored Cross-Site Scripting and Cross-Frame Scripting issues
Affected products
- purethemes WorkScout: before 2.0.33 — fixed in 2.0.33
- PureThemes Workscout Core: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: purethemes WorkScout 2.0.33; PureThemes Workscout Core 1.3.4. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-02-10%5D-%5BWordPress%5D-%5BCWE-79%5D-WorkScout-WordPress-Theme-v2.0.33.txt
- https://wpscan.com/vulnerability/2365a9d0-f6f4-4602-9804-5af23d0cb11d
- https://m0ze.ru/vulnerability/%5B2021-02-10%5D-%5BWordPress%5D-%5BCWE-79%5D-WorkScout-WordPress-Theme-v2.0.33.txt
- https://wpscan.com/vulnerability/2365a9d0-f6f4-4602-9804-5af23d0cb11d
Get alerted when CVE-2021-24246 or the next vulnerability affects your stack