What’s Vulnerable › Vulnerabilities
CVE-2021-24255: Essential Addons for Elementor < 4.5.4 - Contributor+ Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Essential Addons for Elementor Lite WordPress Plugin before 4.5.4 has two widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, both via a similar method.
Affected products
- wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets 4.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7fb708da-e8c4-4455-b4f9-c4ad72f877da
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/7fb708da-e8c4-4455-b4f9-c4ad72f877da
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24255 or the next vulnerability affects your stack