What’s Vulnerable › Vulnerabilities
CVE-2021-24256: Elementor - Header, Footer & Blocks Template < 1.5.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Elementor – Header, Footer & Blocks Template” WordPress Plugin before 1.5.8 has two widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template 1.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a9412fed-aed3-4931-a504-1a86f876892e
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/a9412fed-aed3-4931-a504-1a86f876892e
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24256 or the next vulnerability affects your stack