What’s Vulnerable › Vulnerabilities
CVE-2021-24258: ElementsKit and ElementsKit Pro < 2.2.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Elements Kit Lite and Elements Kit Pro WordPress Plugins before 2.2.0 have a number of widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- roxnor ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: roxnor ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor 2.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/47b47b86-899b-4de3-8a3c-2d5d1774298f
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/47b47b86-899b-4de3-8a3c-2d5d1774298f
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24258 or the next vulnerability affects your stack