What’s Vulnerable › Vulnerabilities
CVE-2021-24259: Elementor Addon Elements < 1.11.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Elementor Addon Elements” WordPress Plugin before 1.11.2 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- wpvibes Addon Elements for Elementor (formerly Elementor Addon Elements): before 1.11.2 — fixed in 1.11.2
How to fix
Upgrade to a fixed version: wpvibes Addon Elements for Elementor (formerly Elementor Addon Elements) 1.11.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0719063f-7743-4a34-94b9-f67fd98e5990
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/0719063f-7743-4a34-94b9-f67fd98e5990
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24259 or the next vulnerability affects your stack