What’s Vulnerable › Vulnerabilities
CVE-2021-24264: Image Hover Effects - Elementor Addon < 1.3.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Image Hover Effects – Elementor Addon” WordPress Plugin before 1.3.4 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- Image Hover Effects – Elementor Addon: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: Image Hover Effects – Elementor Addon 1.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7fd89a49-fbb0-4308-836b-1f12dc585b1f
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/7fd89a49-fbb0-4308-836b-1f12dc585b1f
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24264 or the next vulnerability affects your stack