What’s Vulnerable › Vulnerabilities
CVE-2021-24267: All-in-One Addons for Elementor - WidgetKit < 2.3.10 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “All-in-One Addons for Elementor – WidgetKit” WordPress Plugin before 2.3.10 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- shamsbd71 All-in-One Addons for Elementor – WidgetKit: before 2.3.10 — fixed in 2.3.10
How to fix
Upgrade to a fixed version: shamsbd71 All-in-One Addons for Elementor – WidgetKit 2.3.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0c96f3a1-d192-481f-9035-5393f4aadc19
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/0c96f3a1-d192-481f-9035-5393f4aadc19
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24267 or the next vulnerability affects your stack