What’s Vulnerable › Vulnerabilities
CVE-2021-24268: JetWidgets For Elementor < 1.0.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “JetWidgets For Elementor” WordPress Plugin before 1.0.9 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- jetmonsters JetWidgets For Elementor: before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: jetmonsters JetWidgets For Elementor 1.0.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/68ecb965-2a9d-4e67-b069-c3dbfb14016b
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/68ecb965-2a9d-4e67-b069-c3dbfb14016b
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24268 or the next vulnerability affects your stack