What’s Vulnerable › Vulnerabilities
CVE-2021-24269: Sina Extension for Elementor < 3.3.12 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Sina Extension for Elementor” WordPress Plugin before 3.3.12 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- shaonsina Sina Extension for Elementor: before 3.3.12 — fixed in 3.3.12
How to fix
Upgrade to a fixed version: shaonsina Sina Extension for Elementor 3.3.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/df953a91-f1d8-42e9-8966-f2012d4f97c9
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/df953a91-f1d8-42e9-8966-f2012d4f97c9
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24269 or the next vulnerability affects your stack