What’s Vulnerable › Vulnerabilities
CVE-2021-24270: DethemeKit For Elementor < 1.5.5.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “DeTheme Kit for Elementor” WordPress Plugin before 1.5.5.5 has a widget that is vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- DethemeKit For Elementor: before 1.5.5.5 — fixed in 1.5.5.5
How to fix
Upgrade to a fixed version: DethemeKit For Elementor 1.5.5.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/67967784-18b6-4e41-9597-3a4c051f3978
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24270 or the next vulnerability affects your stack