What’s Vulnerable › Vulnerabilities
CVE-2021-24271: Ultimate Addons for Elementor < 1.30.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The “Ultimate Addons for Elementor” WordPress Plugin before 1.30.0 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Affected products
- Brainstorm Force Ultimate Addons for Elementor: before 1.30.0 — fixed in 1.30.0
How to fix
Upgrade to a fixed version: Brainstorm Force Ultimate Addons for Elementor 1.30.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1ce8e188-6ded-413e-b4d1-bf80258acf79
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
- https://wpscan.com/vulnerability/1ce8e188-6ded-413e-b4d1-bf80258acf79
- https://www.wordfence.com/blog/2021/04/recent-patches-rock-the-elementor-ecosystem/
Get alerted when CVE-2021-24271 or the next vulnerability affects your stack