What’s Vulnerable › Vulnerabilities
CVE-2021-24276: Contact Form by Supsystic < 1.7.15 - Reflected Cross-Site scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form by Supsystic WordPress plugin before 1.7.15 did not sanitise the tab parameter of its options page before outputting it in an attribute, leading to a reflected Cross-Site Scripting issue
Affected products
- supsystic Contact Form by Supsystic: before 1.7.15 — fixed in 1.7.15
How to fix
Upgrade to a fixed version: supsystic Contact Form by Supsystic 1.7.15. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164308/WordPress-Contact-Form-1.7.14-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/1301123c-5e63-432a-ab90-3221ca532d9c
- http://packetstormsecurity.com/files/164308/WordPress-Contact-Form-1.7.14-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/1301123c-5e63-432a-ab90-3221ca532d9c
Get alerted when CVE-2021-24276 or the next vulnerability affects your stack