What’s Vulnerable › Vulnerabilities
CVE-2021-24291: Photo Gallery < 1.5.69 - Multiple Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Photo Gallery by 10Web – Mobile-Friendly Image Gallery WordPress plugin before 1.5.69 was vulnerable to Reflected Cross-Site Scripting (XSS) issues via the gallery_id, tag, album_id and _id GET parameters passed to the bwg_frontend_data AJAX action (available to both unauthenticated and authenticated users)
Affected products
- 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery: before 1.5.69 — fixed in 1.5.69
How to fix
Upgrade to a fixed version: 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery 1.5.69. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/162227/
- https://wpscan.com/vulnerability/cfb982b2-8b6d-4345-b3ab-3d2b130b873a
- https://packetstormsecurity.com/files/162227/
- https://wpscan.com/vulnerability/cfb982b2-8b6d-4345-b3ab-3d2b130b873a
Get alerted when CVE-2021-24291 or the next vulnerability affects your stack