What’s Vulnerable › Vulnerabilities
CVE-2021-24296: WP Customer Reviews < 3.5.6 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Customer Reviews WordPress plugin before 3.5.6 did not sanitise some of its settings, allowing high privilege users such as administrators to set XSS payloads in them which will then be triggered in pages where reviews are enabled
Affected products
- bompus WP Customer Reviews: before 3.5.6 — fixed in 3.5.6
How to fix
Upgrade to a fixed version: bompus WP Customer Reviews 3.5.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c450f54a-3372-49b2-8ad8-68d5cc0dd49e
- https://wpscan.com/vulnerability/c450f54a-3372-49b2-8ad8-68d5cc0dd49e
Get alerted when CVE-2021-24296 or the next vulnerability affects your stack