What’s Vulnerable › Vulnerabilities
CVE-2021-24297: Goto < 2.1 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Goto WordPress theme before 2.1 did not properly sanitize the formvalue JSON POST parameter in its tl_filter AJAX action, leading to an unauthenticated Reflected Cross-site Scripting (XSS) vulnerability.
Affected products
- Goto: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: Goto 2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a64a3b2e-7924-47aa-96e8-3aa02a6cdccc
- https://wpscan.com/vulnerability/a64a3b2e-7924-47aa-96e8-3aa02a6cdccc
Get alerted when CVE-2021-24297 or the next vulnerability affects your stack