What’s Vulnerable › Vulnerabilities
CVE-2021-24308: LifterLMS < 4.21.1 - Authenticated Stored XSS in Edit Profile
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The 'State' field of the Edit profile page of the LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.1 is not properly sanitised when output in the About section of the profile page, leading to a stored Cross-Site Scripting issue. This could allow low privilege users (such as students) to elevate their privilege via an XSS attack when an admin will view their profile.
Affected products
- chrisbadgett LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes: before 4.21.1 — fixed in 4.21.1
How to fix
Upgrade to a fixed version: chrisbadgett LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes 4.21.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162856/WordPress-LifterLMS-4.21.0-Cross-Site-Scripting.html
- https://github.com/gocodebox/lifterlms/releases/tag/4.21.1
- https://wpscan.com/vulnerability/f29f68a5-6575-441d-98c9-867145f2b082
- http://packetstormsecurity.com/files/162856/WordPress-LifterLMS-4.21.0-Cross-Site-Scripting.html
- https://github.com/gocodebox/lifterlms/releases/tag/4.21.1
- https://wpscan.com/vulnerability/f29f68a5-6575-441d-98c9-867145f2b082
Get alerted when CVE-2021-24308 or the next vulnerability affects your stack