What’s Vulnerable › Vulnerabilities
CVE-2021-24312: WP Super Cache < 1.7.3 - Authenticated Remote Code Execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-94
Description
The parameters $cache_path, $wp_cache_debug_ip, $wp_super_cache_front_page_text, $cache_scheduled_time, $cached_direct_pages used in the settings of WP Super Cache WordPress plugin before 1.7.3 result in RCE because they allow input of '$' and '\n'. This is due to an incomplete fix of CVE-2021-24209.
Affected products
- WP Super Cache: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: WP Super Cache 1.7.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2142c3d3-9a7f-4e3c-8776-d469a355d62f
- https://wpscan.com/vulnerability/2142c3d3-9a7f-4e3c-8776-d469a355d62f
Get alerted when CVE-2021-24312 or the next vulnerability affects your stack