What’s Vulnerable › Vulnerabilities
CVE-2021-24314: Goto < 2.1 - Unauthenticated Blind SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-17 · updated 2026-06-17
- Weakness: CWE-89
Description
The Goto WordPress theme before 2.1 did not sanitise, validate of escape the keywords GET parameter from its listing page before using it in a SQL statement, leading to an Unauthenticated SQL injection issue
Affected products
- Goto: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: Goto 2.1. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-03-24%5D-%5BWordPress%5D-%5BCWE-89%5D-Goto-WordPress-Theme-v2.0.txt
- https://wpscan.com/vulnerability/1cc6dc17-b019-49dd-8149-c8bba165eb30
- https://m0ze.ru/vulnerability/%5B2021-03-24%5D-%5BWordPress%5D-%5BCWE-89%5D-Goto-WordPress-Theme-v2.0.txt
- https://wpscan.com/vulnerability/1cc6dc17-b019-49dd-8149-c8bba165eb30
Get alerted when CVE-2021-24314 or the next vulnerability affects your stack