What’s Vulnerable › Vulnerabilities
CVE-2021-24315: Give WP < 2.10.4 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The GiveWP – Donation Plugin and Fundraising Platform WordPress plugin before 2.10.4 did not sanitise or escape the Background Image field of its Stripe Checkout Setting and Logo field in its Email settings, leading to authenticated (admin+) Stored XSS issues.
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 2.10.4 — fixed in 2.10.4
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.10.4. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-04-02%5D-%5BWordPress%5D-%5BCWE-79%5D-GiveWP-WordPress-Plugin-v2.10.3.txt
- https://wpscan.com/vulnerability/006b37c9-641c-4676-a315-9b6053e001d2
- https://m0ze.ru/vulnerability/%5B2021-04-02%5D-%5BWordPress%5D-%5BCWE-79%5D-GiveWP-WordPress-Plugin-v2.10.3.txt
- https://wpscan.com/vulnerability/006b37c9-641c-4676-a315-9b6053e001d2
Get alerted when CVE-2021-24315 or the next vulnerability affects your stack