What’s Vulnerable › Vulnerabilities
CVE-2021-24319: Bello < 1.6.0 - Authenticated Cross-Site Scripting (XSS) and XFS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Bello - Directory & Listing WordPress theme before 1.6.0 did not properly sanitise its post_excerpt parameter before outputting it back in the shop/my-account/bello-listing-endpoint/ page, leading to a Cross-Site Scripting issue
Affected products
- BoldThemes Bello - Directory & Listing: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: BoldThemes Bello - Directory & Listing 1.6.0. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-03-21%5D-%5BWordPress%5D-%5BCWE-1021%5D-Bello-WordPress-Theme-v1.5.9.txt
- https://wpscan.com/vulnerability/2c274eb7-25f1-49d4-a2c8-8ce8cecebe68
- https://m0ze.ru/vulnerability/%5B2021-03-21%5D-%5BWordPress%5D-%5BCWE-1021%5D-Bello-WordPress-Theme-v1.5.9.txt
- https://wpscan.com/vulnerability/2c274eb7-25f1-49d4-a2c8-8ce8cecebe68
Get alerted when CVE-2021-24319 or the next vulnerability affects your stack