What’s Vulnerable › Vulnerabilities
CVE-2021-24322: Database Backup for WordPress < 2.4 - Authenticated Persistent Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Database Backup for WordPress plugin before 2.4 did not escape the backup_recipient POST parameter in before output it back in the attribute of an HTML tag, leading to a Stored Cross-Site Scripting issue.
Affected products
- Database Backup for WordPress: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: Database Backup for WordPress 2.4. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-04-04%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-DB-Backup-WordPress-Plugin-v2.3.3.txt
- https://wpscan.com/vulnerability/6bea6301-0762-45c3-a4eb-15d6ac4f9f37
- https://m0ze.ru/vulnerability/%5B2021-04-04%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-DB-Backup-WordPress-Plugin-v2.3.3.txt
- https://wpscan.com/vulnerability/6bea6301-0762-45c3-a4eb-15d6ac4f9f37
Get alerted when CVE-2021-24322 or the next vulnerability affects your stack