What’s Vulnerable › Vulnerabilities
CVE-2021-24323: Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-17 · updated 2026-06-17
- Weakness: CWE-79
Description
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
Affected products
- Automattic WooCommerce: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: Automattic WooCommerce 5.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6d262555-7ae4-4e36-add6-4baa34dc3010
- https://wpscan.com/vulnerability/6d262555-7ae4-4e36-add6-4baa34dc3010
Get alerted when CVE-2021-24323 or the next vulnerability affects your stack