What’s Vulnerable › Vulnerabilities
CVE-2021-24329: WP Super Cache < 1.7.3 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Super Cache WordPress plugin before 1.7.3 did not properly sanitise its wp_cache_location parameter in its settings, which could lead to a Stored Cross-Site Scripting issue.
Affected products
- WP Super Cache: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: WP Super Cache 1.7.3. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-03-23%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-Super-Cache-WordPress-Plugin-v1.7.2.txt
- https://wpscan.com/vulnerability/9df86d05-1408-4c22-af55-5e3d44249fd0
- https://m0ze.ru/vulnerability/%5B2021-03-23%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-Super-Cache-WordPress-Plugin-v1.7.2.txt
- https://wpscan.com/vulnerability/9df86d05-1408-4c22-af55-5e3d44249fd0
Get alerted when CVE-2021-24329 or the next vulnerability affects your stack