What’s Vulnerable › Vulnerabilities
CVE-2021-24332: Autoptimize < 2.8.4 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Autoptimize WordPress plugin before 2.8.4 was missing proper escaping and sanitisation in some of its settings, allowing high privilege users to set XSS payloads in them, leading to stored Cross-Site Scripting issues
Affected products
- Autoptimize: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: Autoptimize 2.8.4. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-04-01%5D-%5BWordPress%5D-%5BCWE-79%5D-Autoptimize-WordPress-Plugin-v2.8.3.txt
- https://wpscan.com/vulnerability/6678e064-ce21-4bb2-8c50-061073fb22fb
- https://m0ze.ru/vulnerability/%5B2021-04-01%5D-%5BWordPress%5D-%5BCWE-79%5D-Autoptimize-WordPress-Plugin-v2.8.3.txt
- https://wpscan.com/vulnerability/6678e064-ce21-4bb2-8c50-061073fb22fb
Get alerted when CVE-2021-24332 or the next vulnerability affects your stack