What’s Vulnerable › Vulnerabilities
CVE-2021-24339: Pods < 2.7.27 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pods – Custom Content Types and Fields WordPress plugin before 2.7.27 was vulnerable to an Authenticated Stored Cross-Site Scripting (XSS) security vulnerability within the 'Menu Label' field parameter.
Affected products
- sc0ttkclark Pods – Custom Content Types and Fields: before 2.7.27 — fixed in 2.7.27
How to fix
Upgrade to a fixed version: sc0ttkclark Pods – Custom Content Types and Fields 2.7.27. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8e72236d-f620-4503-a324-dcf49405351b
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-24339
- https://wpscan.com/vulnerability/8e72236d-f620-4503-a324-dcf49405351b
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-24339
Get alerted when CVE-2021-24339 or the next vulnerability affects your stack