What’s Vulnerable › Vulnerabilities
CVE-2021-24343: iFlyChat – WordPress Chat < 4.7.0 - Admin+ Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The iFlyChat WordPress plugin before 4.7.0 does not sanitise its APP ID setting before outputting it back in the page, leading to an authenticated Stored Cross-Site Scripting issue
Affected products
- iFlyChat Team iFlyChat – WordPress Chat: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: iFlyChat Team iFlyChat – WordPress Chat 4.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d6c72d90-e321-47b9-957a-6fea7c944293
- https://wpscan.com/vulnerability/d6c72d90-e321-47b9-957a-6fea7c944293
Get alerted when CVE-2021-24343 or the next vulnerability affects your stack