What’s Vulnerable › Vulnerabilities
CVE-2021-24365: Admin Columns Free (< 4.3.2) & Pro (< 5.5.2) - Authenticated Stored Cross-Site Scripting (XSS) in Custom Field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Admin Columns WordPress plugin Free before 4.3.2 and Pro before 5.5.2 allowed to configure individual columns for tables. Each column had a type. The type "Custom Field" allowed to choose an arbitrary database column to display in the table. There was no escaping applied to the contents of "Custom Field" columns.
Affected products
- AdminColumns Admin Columns: before 4.3.2; before 5.5.2 — fixed in 4.3.2, 5.5.2
How to fix
Upgrade to a fixed version: AdminColumns Admin Columns 4.3.2, 5.5.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fdbeb137-b404-46c7-85fb-394a3bdac388
- https://www.syss.de/fileadmin/dokumente/Publikationen/Advisories/SYSS-2021-032.txt
- https://wpscan.com/vulnerability/fdbeb137-b404-46c7-85fb-394a3bdac388
- https://www.syss.de/fileadmin/dokumente/Publikationen/Advisories/SYSS-2021-032.txt
Get alerted when CVE-2021-24365 or the next vulnerability affects your stack