What’s Vulnerable › Vulnerabilities
CVE-2021-24366: Admin Columns Free < 4.3 & Pro < 5.5.1 - Admin+ Stored XSS in Label
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
Description
The Admin Columns WordPress plugin before 4.3 and Admin Columns Pro WordPress plugin before 5.5.1 do not sanitise and escape its Label settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- AdminColumns Admin Columns: before 4.3; before 5.5.1 — fixed in 4.3, 5.5.1
How to fix
Upgrade to a fixed version: AdminColumns Admin Columns 4.3, 5.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/codepress/admin-columns/commit/b45571ed21d574d13687213a5002e0c68e4442c7
- https://wpscan.com/vulnerability/05427156-4d5c-4aeb-add8-1c574fda5c28
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-24366
- https://github.com/codepress/admin-columns/commit/b45571ed21d574d13687213a5002e0c68e4442c7
- https://wpscan.com/vulnerability/05427156-4d5c-4aeb-add8-1c574fda5c28
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-24366
Get alerted when CVE-2021-24366 or the next vulnerability affects your stack