What’s Vulnerable › Vulnerabilities
CVE-2021-24369: GetPaid < 2.3.4 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
In the GetPaid WordPress plugin before 2.3.4, users with the contributor role and above can create a new Payment Form, however the Label and Help Text input fields were not getting sanitized properly. So it was possible to inject malicious content such as img tags, leading to a Stored Cross-Site Scripting issue which is triggered when the form will be edited, for example when an admin reviews it and could lead to privilege escalation.
Affected products
- Stiofan GetPaid: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Stiofan GetPaid 2.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1d1a731b-78f7-4d97-b40d-80f66700edae
- https://wpscan.com/vulnerability/1d1a731b-78f7-4d97-b40d-80f66700edae
Get alerted when CVE-2021-24369 or the next vulnerability affects your stack