What’s Vulnerable › Vulnerabilities
CVE-2021-24373: WP Hardening < 1.2.2 - Reflected XSS via historyvalue
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Hardening – Fix Your WordPress Security WordPress plugin before 1.2.2 did not sanitise or escape the historyvalue GET parameter before outputting it in a Javascript block, leading to a reflected Cross-Site Scripting issue.
Affected products
- WP Hardening – Fix Your WordPress Security: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: WP Hardening – Fix Your WordPress Security 1.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fcf17278-609f-4f75-8a87-9b4579dee1c8
- https://wpscan.com/vulnerability/fcf17278-609f-4f75-8a87-9b4579dee1c8
Get alerted when CVE-2021-24373 or the next vulnerability affects your stack