What’s Vulnerable › Vulnerabilities
CVE-2021-24377: Autoptimize < 2.7.8 - Race Condition leading to RCE
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-362
Description
The Autoptimize WordPress plugin before 2.7.8 attempts to remove potential malicious files from the extracted archive uploaded via the 'Import Settings' feature, however this is not sufficient to protect against RCE as a race condition can be achieved in between the moment the file is extracted on the disk but not yet removed. It is a bypass of CVE-2020-24948.
Affected products
- Autoptimize: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Autoptimize 2.7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/85c0a564-2e56-413d-bc3a-1039343207e4
- https://wpscan.com/vulnerability/85c0a564-2e56-413d-bc3a-1039343207e4
Get alerted when CVE-2021-24377 or the next vulnerability affects your stack