What’s Vulnerable › Vulnerabilities
CVE-2021-24378: Autoptimize < 2.7.8 - Authenticated Stored XSS via File Upload
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Autoptimize WordPress plugin before 2.7.8 does not check for malicious files such as .html in the archive uploaded via the 'Import Settings' feature. As a result, it is possible for a high privilege user to upload a malicious file containing JavaScript code inside an archive which will execute when a victim visits index.html inside the plugin directory.
Affected products
- Autoptimize: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Autoptimize 2.7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/375bd694-1a30-41af-bbd4-8a8ee54f0dbf
- https://wpscan.com/vulnerability/375bd694-1a30-41af-bbd4-8a8ee54f0dbf
Get alerted when CVE-2021-24378 or the next vulnerability affects your stack