What’s Vulnerable › Vulnerabilities
CVE-2021-24381: NinjaForms < 3.5.8.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Forms Contact Form WordPress plugin before 3.5.8.2 does not sanitise and escape the custom class name of the form field created, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Ninjaforms Contact Form: before 3.5.8.2 — fixed in 3.5.8.2
How to fix
Upgrade to a fixed version: Ninjaforms Contact Form 3.5.8.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e383fae6-e0da-4aba-bb62-adf51c01bf8d
- https://wpscan.com/vulnerability/e383fae6-e0da-4aba-bb62-adf51c01bf8d
Get alerted when CVE-2021-24381 or the next vulnerability affects your stack