What’s Vulnerable › Vulnerabilities
CVE-2021-24389: FoodBakery < 2.2 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Foodbakery WordPress plugin before 2.2, used in the FoodBakery WordPress theme before 2.2 did not properly sanitize the foodbakery_radius parameter before outputting it back in the response, leading to an unauthenticated Reflected Cross-Site Scripting (XSS) vulnerability.
Affected products
- Chimpstudio FoodBakery: before 2.2 — fixed in 2.2
How to fix
Upgrade to a fixed version: Chimpstudio FoodBakery 2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/23b8b8c4-cded-4887-a021-5f3ea610213b
- https://wpscan.com/vulnerability/23b8b8c4-cded-4887-a021-5f3ea610213b
Get alerted when CVE-2021-24389 or the next vulnerability affects your stack