What’s Vulnerable › Vulnerabilities
CVE-2021-24407: Jannah < 5.4.5 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Jannah WordPress theme before 5.4.5 did not properly sanitize the 'query' POST parameter in its tie_ajax_search AJAX action, leading to a Reflected Cross-site Scripting (XSS) vulnerability.
Affected products
- TieLabs Jannah: before 5.4.5 — fixed in 5.4.5
How to fix
Upgrade to a fixed version: TieLabs Jannah 5.4.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fba9f010-1202-4eea-a6f5-78865c084153
- https://wpscan.com/vulnerability/fba9f010-1202-4eea-a6f5-78865c084153
Get alerted when CVE-2021-24407 or the next vulnerability affects your stack