What’s Vulnerable › Vulnerabilities
CVE-2021-24408: Prismatic < 2.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Prismatic WordPress plugin before 2.8 does not sanitise or validate some of its shortcode parameters, allowing users with a role as low as Contributor to set Cross-Site payload in them. A post made by a contributor would still have to be approved by an admin to have the XSS trigger able in the frontend, however, higher privilege users, such as editor could exploit this without the need of approval, and even when the blog disallows the unfiltered_html capability.
Affected products
- Jeff Starr Prismatic: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Jeff Starr Prismatic 2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/51855853-e7bd-425f-802c-824209f4f84d
- https://wpscan.com/vulnerability/51855853-e7bd-425f-802c-824209f4f84d
Get alerted when CVE-2021-24408 or the next vulnerability affects your stack