What’s Vulnerable › Vulnerabilities
CVE-2021-24409: Prismatic < 2.8 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Prismatic WordPress plugin before 2.8 does not escape the 'tab' GET parameter before outputting it back in an attribute, leading to a reflected Cross-Site Scripting issue which will be executed in the context of a logged in administrator
Affected products
- Jeff Starr Prismatic: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Jeff Starr Prismatic 2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ae3cd3ed-aecd-4d8c-8a2b-2936aaaef0cf
- https://wpscan.com/vulnerability/ae3cd3ed-aecd-4d8c-8a2b-2936aaaef0cf
Get alerted when CVE-2021-24409 or the next vulnerability affects your stack