What’s Vulnerable › Vulnerabilities
CVE-2021-24412: Html5 Audio Player < 2.1.3 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Html5 Audio Player – Audio Player for WordPress plugin before 2.1.3 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Affected products
- bPlugins Html5 Audio Player: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: bPlugins Html5 Audio Player 2.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c4ed3e52-cbe0-46dc-ab43-65de78cfb225
- https://wpscan.com/vulnerability/c4ed3e52-cbe0-46dc-ab43-65de78cfb225
Get alerted when CVE-2021-24412 or the next vulnerability affects your stack