What’s Vulnerable › Vulnerabilities
CVE-2021-24413: Easy Twitter Feed < 1.2 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Twitter Feed WordPress plugin before 1.2 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Affected products
- Easy Twitter Feed: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: Easy Twitter Feed 1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24
- https://wpscan.com/vulnerability/ce6d17c3-6741-4c80-ab13-e1824960ae24
Get alerted when CVE-2021-24413 or the next vulnerability affects your stack