What’s Vulnerable › Vulnerabilities
CVE-2021-24414: YT Player < 1.4 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Video Player for YouTube WordPress plugin before 1.4 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Affected products
- Video Player for YouTube: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: Video Player for YouTube 1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e20b805d-eb11-4702-9803-77de276000ac
- https://wpscan.com/vulnerability/e20b805d-eb11-4702-9803-77de276000ac
Get alerted when CVE-2021-24414 or the next vulnerability affects your stack