What’s Vulnerable › Vulnerabilities
CVE-2021-24416: StreamCast < 2.1.1 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The StreamCast – Radio Player for WordPress plugin before 2.1.1 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Affected products
- StreamCast – Radio Player for WordPress: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: StreamCast – Radio Player for WordPress 2.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/260c7e2d-d48c-42d6-ae05-bad3f3bac01d
- https://wpscan.com/vulnerability/260c7e2d-d48c-42d6-ae05-bad3f3bac01d
Get alerted when CVE-2021-24416 or the next vulnerability affects your stack