What’s Vulnerable › Vulnerabilities
CVE-2021-24420: Request a Quote < 2.3.4 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Request a Quote WordPress plugin before 2.3.4 did not sanitise and escape some of its quote fields when adding/editing a quote as admin, leading to Stored Cross-Site scripting issues when the quote is output in the 'All Quotes" table.
Affected products
- Request a Quote: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Request a Quote 2.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/426eafb1-0261-4e7e-8c70-75bf4c476f18
- https://wpscan.com/vulnerability/426eafb1-0261-4e7e-8c70-75bf4c476f18
Get alerted when CVE-2021-24420 or the next vulnerability affects your stack