What’s Vulnerable › Vulnerabilities
CVE-2021-24424: WP Reset < 1.90 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Reset – Most Advanced WordPress Reset Tool WordPress plugin before 1.90 did not sanitise or escape its extra_data parameter when creating a snapshot via the admin dashboard, leading to an authenticated Stored Cross-Site Scripting issue
Affected products
- webfactory WP Reset: before 1.90 — fixed in 1.90
How to fix
Upgrade to a fixed version: webfactory WP Reset 1.90. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-05-26%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-Reset-WordPress-Plugin-v1.86.txt
- https://wpscan.com/vulnerability/90cf8f9d-4d37-405d-b161-239bdb281828
- https://m0ze.ru/vulnerability/%5B2021-05-26%5D-%5BWordPress%5D-%5BCWE-79%5D-WP-Reset-WordPress-Plugin-v1.86.txt
- https://wpscan.com/vulnerability/90cf8f9d-4d37-405d-b161-239bdb281828
Get alerted when CVE-2021-24424 or the next vulnerability affects your stack