What’s Vulnerable › Vulnerabilities
CVE-2021-24425: myStickymenu < 2.5.2 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Notification Bar, Sticky Menu on Scroll, and Sticky Header for Any Theme – myStickymenu WordPress plugin before 2.5.2 does not sanitise or escape its Bar Text settings, allowing hight privilege users to use malicious JavaScript in it, leading to a Stored Cross-Site Scripting issue, which will be triggered in the plugin's setting, as well as all front-page of the blog (when the Welcome bar is active)
Affected products
- Floating Notification Bar, Sticky Menu on Scroll, and Sticky Header for Any Theme – myStickymenu: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Floating Notification Bar, Sticky Menu on Scroll, and Sticky Header for Any Theme – myStickymenu 2.5.2. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-05-21%5D-%5BWordPress%5D-%5BCWE-79%5D-MyStickymenu-WordPress-Plugin-v2.5.1.txt
- https://wpscan.com/vulnerability/14632fa8-597e-49ff-8583-9797208a3583
- https://m0ze.ru/vulnerability/%5B2021-05-21%5D-%5BWordPress%5D-%5BCWE-79%5D-MyStickymenu-WordPress-Plugin-v2.5.1.txt
- https://wpscan.com/vulnerability/14632fa8-597e-49ff-8583-9797208a3583
Get alerted when CVE-2021-24425 or the next vulnerability affects your stack