What’s Vulnerable › Vulnerabilities
CVE-2021-24427: W3 Total Cache < 2.1.3 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The W3 Total Cache WordPress plugin before 2.1.3 did not sanitise or escape some of its CDN settings, allowing high privilege users to use JavaScript in them, which will be output in the page, leading to an authenticated Stored Cross-Site Scripting issue
Affected products
- boldgrid W3 Total Cache: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: boldgrid W3 Total Cache 2.1.3. Check the vendor advisory for mitigations.
References
- https://m0ze.ru/vulnerability/%5B2021-04-25%5D-%5BWordPress%5D-%5BCWE-79%5D-W3-Total-Cache-WordPress-Plugin-v2.1.2.txt
- https://wpscan.com/vulnerability/5da5ce9a-82a6-404f-8dec-795d7905b3f9
- https://m0ze.ru/vulnerability/%5B2021-04-25%5D-%5BWordPress%5D-%5BCWE-79%5D-W3-Total-Cache-WordPress-Plugin-v2.1.2.txt
- https://wpscan.com/vulnerability/5da5ce9a-82a6-404f-8dec-795d7905b3f9
Get alerted when CVE-2021-24427 or the next vulnerability affects your stack